LMS QNAP neues Plugin V 7.9.2

karlek
Moderator
Beiträge: 1526
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: LMS QNAP neues Plugin V 7.9.2

Beitrag von karlek » 22. Juni 2019 14:33

Welche Berechtigungen hast Du squeezeboxserver denn genau gegeben und wie?

Schau mal im Server Log nach Fehlern.

Im slimdevices-Forum gibt es auch Meldungen zu einem Fehler, die Berechtigungen betreffend. Das habe ich aber nur überflogen gehabt und dürfte erstmal nichts mit Deinem Problem, den Musik-Ordner nicht auswählen zu können, zu tun haben.

Ja, es geht jetzt ganz ohne SSOTS. Nichtsdestrotrotz gab es mal bei der letzten LMS-mit-SSOTS-Version eine Warnung, wenn man erweiterte Berechtigungen auf dem QNAP eingeschaltet hatte:
Sometimes the music(folder) is not visable, when using advanced user rights. Many thanks to Spag for the following solution:
1. Download and install WinSCP: http://winscp.net/
2. Log in to the QNAP NAS with admin user and password
3. Navigate to your music and playlist root folder(s)
4. Right click the folder(s) and set the octal settings to "0770" and set group, owner and permissions recursively. The most important thing is, that you set the group to "everyone [100]" and the owner to a local user, that is not the admin. If the group and owner are admin, squeezebox will not find any files.
5. Set the correct music and playlist folders in the Squeezbox Server's settings page.
(6) If your music files is in a subfolder and not in the root of a share, you might have to manually edit the path to the music folder and the playlist folder in the Squeezebox Server's settings page.
7. Scan the music library and wait. It should find all your files now.

Benutzeravatar
OliverCJ
Beiträge: 55
Registriert: 21. Juni 2011 13:02
SqueezeBox: Radio
SqueezeBox: Touch
SqueezeBox: SqueezePlay
SqueezeBox Server läuft auf: QNAP TS-219P+
Wohnort: Bergisch Gladbach

Re: LMS QNAP neues Plugin V 7.9.2

Beitrag von OliverCJ » 22. Juni 2019 21:08

Also ich habe dem Benutzer "squeezeboxserver" (keine Ahnung ob das überhaupt der richtige User ist, aber den gibt es erst seit der Installation) einfach über die "Berechtigung für Freigabeordner" die Schreib-/Leseberechtigung auf "Multimedia" gegeben und dabei gesagt, dass die Änderungen auch auf die Subordner angewendet werden sollen.

Schaue ich mir den Ordner in der FileStation an und lasse mir die Eigenschaften anzeigen, wird es mir auch dort korrekt angezeigt
tempsnip.png
Erweiterte Berechtigungen nutze ich übrigens nicht.

Aber ich komme eh schon wieder mit was neuem um die Ecke... Was ist das nu wieder:???
qlms.PNG
Wie komme ich genau an die Logs?

D A N K E ! ! !
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Wenn die Klügeren immer nachgeben, wird die Welt bald von den Dummen beherrscht.

karlek
Moderator
Beiträge: 1526
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: LMS QNAP neues Plugin V 7.9.2

Beitrag von karlek » 22. Juni 2019 23:11

"Das schon wieder" ist die "Classic"-Darstellung der LMS-Weboberfläche. Du kannst sie wie folgt ändern:
  1. Server-Einstellungen
  2. Benutzoberfläche
  3. Web-Benutzeroberfläche auf "Standard"
Die Logs findest Du im Webinterface unter "Einstellungen"-"Informationen" ganz unten.

Ob Du über das QNAP-Webinterface die Berechtigungen vollumfassend einstellen (bzw. korrigieren, denn eingerichtet sollten sie während der Installation werden) kannst, kann ich Dir nicht sagen. Ich glaube eher nicht. Bei mir ist er z.B. deaktiviert. Auf jeden Fall sollte RO für Musik genügen. squeezeboxserver ändert nichts an Musikdateien, nur für den Ordner mit den Wiedergabelisten braucht er Schreibrechte (und für den Verwaltungskram, aber den bekommst Du so einfach nicht ins Webinterface, also vergessen...)

Schau Dir mal das Server Log dazu an.

Benutzeravatar
OliverCJ
Beiträge: 55
Registriert: 21. Juni 2011 13:02
SqueezeBox: Radio
SqueezeBox: Touch
SqueezeBox: SqueezePlay
SqueezeBox Server läuft auf: QNAP TS-219P+
Wohnort: Bergisch Gladbach

Re: LMS QNAP neues Plugin V 7.9.2

Beitrag von OliverCJ » 24. Juni 2019 08:55

Guten Morgen Karlek,

vielen Dank für Deine Hilfe! Du hast mich zumindest auf die richtige Spur gebracht... Mit WinSCP konnte ich die Einstellungen setzen. Zwar nicht so, wie in dem von Dir geposteten Auszug, aber jetzt geht es. Bei mir ist das Octal Setting "0774". Damit geht es endlich wieder.

Auch das mit dem Ändern der Classic-Darstellung war gar nicht so einfach. Musste ich ungefähr 4x hin und her ändern, bis das dann irgendwann mal korrekt angezeigt wurde.

Jetzt momentan scannt er gerade die Bibliothek ein.. Da bleibt mir das Radio vielleicht doch noch ein wenig erhalten.
Und wenn ich mal ganz viel Zeit und Muße habe, dann setze ich das NAS mal komplett neu auf. Da scheint ja doch irgendwas im Argen zu liegen.

Danke noch mal und viele Grüße
Oliver
Wenn die Klügeren immer nachgeben, wird die Welt bald von den Dummen beherrscht.

wus
Beiträge: 45
Registriert: 3. September 2012 12:27
SqueezeBox: Touch
SqueezeBox: Classic
SqueezeBox Server läuft auf: QNAP

Re: LMS QNAP neues Plugin V 7.9.2

Beitrag von wus » 26. Juni 2019 20:44

karlek hat geschrieben:
20. Juni 2019 14:24
Dazu im AppCenter oben rechts auf das Steuerrad ("Einstellungen") klicken und im folgenden Dialog im zweiten Reiter "App-Archiv" die Adresse einfügen.
Dafür erst mal vielen Dank. Hat bei mir (TS-251+ mit QTS 4.3.6.0979 (2019/06/20)) problemlos funktioniert. Konnte den QLogitechMediaServer 2.09.01 problemlos installieren.

Aber wenn ich "Öffnen" klicke kriege ich ein Pop-up "Sichere Verbindungen (https://) werden bei dieser Applikation nicht unterstützt. Wirklich öffnen?"

Wenn ich hier "Ja" klicke öffnet der FF zwar einen neuen Tab, darin wird aber nur "Fehler: Verbindung fehlgeschlagen" und der dazu gehörige übliche Sermon angezeigt.

Ich hab das NAS auch schon mal neu gestartet, als ich danach den QLogitechMediaServer anklickte meldete das System sowas wie "wird gerade gestartet, später nochmal probieren". So weit so gut, aber als ich einige Minuten später nochmal probierte kreigte ich das gleiche Pop-up wie vor dem NAS-Neustart, und nach wie vor keine Verbindung.

Wie kriege ich das gebacken?

karlek
Moderator
Beiträge: 1526
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: LMS QNAP neues Plugin V 7.9.2

Beitrag von karlek » 30. Juni 2019 16:34

Versuch mal eine alte (Oude)Version von hier:
https://www.qnapclub.eu/nl/qpkg/545

wus
Beiträge: 45
Registriert: 3. September 2012 12:27
SqueezeBox: Touch
SqueezeBox: Classic
SqueezeBox Server läuft auf: QNAP

Re: LMS QNAP neues Plugin V 7.9.2

Beitrag von wus » 30. Juni 2019 16:50

Das hatte ich gerade vorhin selber auch entdeckt - trotzdem danke für den Hinweis. Besser spät als nie! Vielleicht nützt es ja mal jemand anderem.

QLMS 2.04.00 läuft inzwischen bei mir, soweit ich bisher festgestellt habe problemlos.

karlek
Moderator
Beiträge: 1526
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: LMS QNAP neues Plugin V 7.9.2

Beitrag von karlek » 30. Juni 2019 17:03

Super! Dann viel Spaß damit! :)

thomasfoerster
Beiträge: 7
Registriert: 8. April 2018 12:24
SqueezeBox: Touch
SqueezeBox Server läuft auf: TS-112P
Als Player noch ein RasPI 3 mit Hifiberry DAC und Picoreplayer 5.0

Falls es jemanden interessiert: für das TS-112P passt X19!

Beitrag von thomasfoerster » 21. Oktober 2019 11:21

Hallo zusammen,

habe bis letzten Samstag immer noch mit SSOTS rumgefummelt, weil ich bis dahin nichts von QLMS wusste.
Hat mich eigentlich nie gestört, den Umweg über SSOTS machen zu müssen, so sind mein telnet und vi auch nicht eingerostet..
Plugins ließen sich im LMS aber nicht mehr aktivieren, und nur deshalb habe ich nach einer Alternative gesucht und wurde auf QLMS hingewiesen.
(Danke an viridarium aus dem Hifi-Forum!)

Da es ja keine Version für x12 gibt, habe ich nacheinander erst x09 und dann x19 installiert, letzteres mit Erfolg.
Auch bei mir ist die Installation eine gefühlte Ewigkeit bei 45% stehengeblieben, bevor es weiterging.

Die Firmware habe ich dann auch gleich auf 4.3.3.1051 build 20190921 aktualisiert, passt.

Endlich kann ich Plugins nach Lust und Laune ausprobieren!

Gruß
Thomas

thomasfoerster
Beiträge: 7
Registriert: 8. April 2018 12:24
SqueezeBox: Touch
SqueezeBox Server läuft auf: TS-112P
Als Player noch ein RasPI 3 mit Hifiberry DAC und Picoreplayer 5.0

Nachtrag zu "für das TS-112P passt X19!"

Beitrag von thomasfoerster » 25. Oktober 2019 22:50

Ach so, falls das aus dem Kontext nicht klar wird:
Ich musste die Images händisch herunterladen und installieren.
Im QNAPClub App-Archiv für die TS-112P taucht leider QLMS nicht auf.
Deshalb gibt es leider auch keine automatischen Updates:-(

Weiß dazu jemand einen Trick?
(Die prefs sichern, QLMS per Hand updaten und die prefs zurückholen würde ich mir natürlich auch lieber jetzt noch sparen..)
Aber vielleicht ist das jetzt auch zu gierig!

Gruß
Thomas