Wetter Plug-In

jono
Beiträge: 107
Registriert: 8. Juni 2011 22:10
SqueezeBox: Touch
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: SqueezePlay
SqueezeBox Server läuft auf: Raspberry pi, Odroid U3
Wohnort: südlich

Re: Wetter Plug-In

Beitrag von jono » 11. März 2019 11:33

Solange es läuft ist ja alles gut, wenn es nicht mehr läuft wird sich vermutlich einer darum kümmern :-). Ich wäre da mal entspannt.

karlek
Moderator
Beiträge: 1427
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: Wetter Plug-In

Beitrag von karlek » 11. März 2019 17:10

bearshare hat geschrieben:
11. März 2019 07:52
Ich habe gehört, dass auch bald die API von weather.com nicht mehr zur Verfügung stehen wird.
Wo hast Du denn das gehört?

bearshare
Beiträge: 9
Registriert: 11. März 2019 07:46
SqueezeBox: Touch

Re: Wetter Plug-In

Beitrag von bearshare » 12. März 2019 05:24

Nicht gehört sondern gelesen - stand im englischsprachigen SB Forum. Nicht garantiert aber wird wegen IBM nicht ausgeschlossen.

Aber übergangsweise würde ich es probieren. Allerdings schaffe ich es nicht, das Repository von SDT weather.com
in de SB zu aktivieren. Wenn ich es importieren will, tut sich nichts obwohl das WU entfernt ist. Der SB Server läuft bei mir auf einem Synology NAS - hat man darüber Zugriff auf das Filesystem der SB? Dann würde ich es manuell kopieren bzw. das alte suchen und löschen...

Ohne Wetter ist meine SBT im Moment nur die Hälfte wert...

karlek
Moderator
Beiträge: 1427
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: Wetter Plug-In

Beitrag von karlek » 12. März 2019 07:56

Hast Du auch das Repo von WU entfernt?
Und ist das Repo ganz unten auch eingetragen und trotzdem findest Du das Plugin nicht?

bearshare
Beiträge: 9
Registriert: 11. März 2019 07:46
SqueezeBox: Touch

Re: Wetter Plug-In

Beitrag von bearshare » 12. März 2019 08:20

Ich habe es entfernt und es ist auch nicht mehr sichtbar.
Aber vielleicht ist es noch nicht sauber raus? Das neue wird in der Zeile unten auch nicht gespeichert nachdem ich auf übernehmen klicke...Wie startet man üblicherweise den SB Server neu?

karlek
Moderator
Beiträge: 1427
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Wetter Plug-In

Beitrag von karlek » 12. März 2019 09:02

Wenn es nicht übernommen wurde, findest Du dazu vielleicht eine Meldung oben im Webinterface oder was im Server-Log.
Neustart sollte bei einem Repo nicht nötig sein. Und wie man neu startet hängt vom System ab, auf dem der LMS läuft. Bei Win und MacOS geht das über einem Dialog, bei einem NAS oder einem RasPi/Odroid über Konsole/Terminal. Modernere LMS-Versionen bieten auch einen Neustart an, nachdem Plugins (de-)aktiviert wurden.

bearshare
Beiträge: 9
Registriert: 11. März 2019 07:46
SqueezeBox: Touch

Re: Wetter Plug-In

Beitrag von bearshare » 13. März 2019 13:51

So richtig komme ich nicht weiter. In den Logs ist nichts zu finden. Ich denke man kann die Installation oder das Entfernen von PlugIns auch über die Konsole machen (\var\home\SqueezeboxServer\Plugins), oder mal den Cache löschen. Aber ich weiß immer noch nicht, wie ich da drauf komme. Über Terminal mit FTP verbinden? Welche Zugangsdaten sind dann erforderlich? Ich kenne nur den Zugang, des Admins, den ich auf dem NAS verwende. Und mit diesem komme ich nicht weiter. Auf dem Windows Server früher war das einfacher, da konnte man direkt auf die Verzeichnisstruktur der SB zugreifen. Aber im NAS geht das irgendwie nicht...

karlek
Moderator
Beiträge: 1427
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: Wetter Plug-In

Beitrag von karlek » 13. März 2019 18:09

So ganz komme ich mit Deinen Antworten bzw. Informationen nicht weiter.

Wenn ich eine falsche Repo-Adresse eingebe und auf Übernehmen klicke, zeigt LMS mir oben auf der Plugin-Seite eine Fehlermeldung an. Und im Log finde ich dann die folgenden Meldungen:

Code: Alles auswählen

[19-03-13 18:00:37.6822] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://sourceforge.net/projects/sdt-weather-com/files/reposit.xml: 404 Not Found
[19-03-13 18:00:37.6836] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://sourceforge.net/projects/sdt-weather-com/files/reposit.xml
Nichtsdestotrotz werde ich danach vom LMS aufgefordert, den Server neu zu starten. Dazu zeigt er bei mir (LMS auf RasPi) einen Dialog, "Neu starten" / "Später starten". Anscheinend muss der LMS dann also neu gestartet werden.
  • Auf welchem NAS läuft der LMS denn bei Dir?
  • Und gibt es da kein APP-Center, oder so, über den man den LMS stoppen und starten kann?
  • Und ein Dialog mit Schaltfläche zum Neustart gibt es bei Dir auch nicht, nachdem Du ein Plugin aktivierst?

bearshare
Beiträge: 9
Registriert: 11. März 2019 07:46
SqueezeBox: Touch

Re: Wetter Plug-In

Beitrag von bearshare » 13. März 2019 20:54

Also ich betreibe den LMS auf einem Synology NAS und ja - darüber kann ich den Server auch starten und stoppen.
Allerdings kommt der Neustart Befehl in der GUI des Servers bei mir nicht nach dem Import...

karlek
Moderator
Beiträge: 1427
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: Wetter Plug-In

Beitrag von karlek » 13. März 2019 21:15

Vermutlich ist Deine LMS-Version für den automatisierten Neustart zu alt. Welche hast Du denn?

Hast Du auch die richtige Adresse für das Repositorium eingetragen? Sie lautet:

Code: Alles auswählen

https://sourceforge.net/projects/sdt-weather-com/files/repo.xml