Spotty Wiedergabe bricht bei langen Stücken ab und springt zum nächsten Titel

macfly1988
Beiträge: 12
Registriert: 11. April 2019 18:51
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox Server läuft auf: Windows 10 Rechner

Spotty Wiedergabe bricht bei langen Stücken ab und springt zum nächsten Titel

Beitrag von macfly1988 » 12. September 2019 21:19

Siehe Betreff.

Im Log steht an dieser Stelle:

[19-09-12 21:04:35.6486] Slim::Utils::OS::Win32::getPriorityClass (750) Error: Slim::Utils::LogCan't get process handle () [Wong number of parameters: expected 0, got 1.]

Liebe Experten: Hat jemand eine Idee, bzw. was kann man da machen?

(LMS auf Win 10, SB Touch synchronisiert mit SB Radio und über AirPlay mit einem ZippMini.)

Danke und schöne Grüße!
Alexander

karlek
Moderator
Beiträge: 1522
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Spotty Wiedergabe bricht bei langen Stücken ab und springt zum nächsten Titel

Beitrag von karlek » 13. September 2019 07:10

War das einmalig oder kommt das häufig vor?
Beim selben Stück an derselben Stelle?
Hast Du es mal ohne Synchronisation getestet?
Das „log“ ist vermutlich zu kurz.
Edit: ist der LMS aktuell?

macfly1988
Beiträge: 12
Registriert: 11. April 2019 18:51
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox Server läuft auf: Windows 10 Rechner

Re: Spotty Wiedergabe bricht bei langen Stücken ab und springt zum nächsten Titel

Beitrag von macfly1988 » 13. September 2019 10:58

Danke für die schnelle Antwort!

Der Effekt tritt bei den gleichen Stücken häufig (aber nicht immer) auf, und dann auch nicht immer an der gleichen Stelle. Häufig nach ca. 10 Minuten, manchmal auch schon nach 5 oder 7 min.
Das einzige Muster ist, dass es sich durchweg um Stücke >5 min handelt. Kürzere Stücke sind fast nie betroffen.

Das Problem tritt auch ohne Synchronisierung auf.

Hier ein Ausschnitt der log-Datei von gestern und heute, als der Fehler einige Male auftrat.
https://www.dropbox.com/s/3rws9hti0ryup ... r.txt?dl=0

LMS-Version: 7.7.6

Danke und schöne Grüße,
Alexander

karlek
Moderator
Beiträge: 1522
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Spotty Wiedergabe bricht bei langen Stücken ab und springt zum nächsten Titel

Beitrag von karlek » 15. September 2019 17:37

Ich komme momentan nie an den Rechner, um das Logfile zu lesen, aber vermutlich würde ich eh nix verstehen. :)
Was Du machen kannst: auf die aktuelle 7.9.1 wechseln oder besser auf die nightly 7.9.2. Bei letzterer ist mir das noch nie aufgefallen. Allerdings weiß ich nicht, ob ich so lange Titel überhaupt gehört habe. Hast Du ein paar Beispiele?

macfly1988
Beiträge: 12
Registriert: 11. April 2019 18:51
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox Server läuft auf: Windows 10 Rechner

Re: Spotty Wiedergabe bricht bei langen Stücken ab und springt zum nächsten Titel

Beitrag von macfly1988 » 16. September 2019 13:57

Ich habe jetzt mal 7.9.2 installiert und werde mal testen, wie es sich jetzt verhält.
(Ich wusste übrigens überhaupt nicht, dass es aktuellere Versionen als die von Logitech angebotenen gibt...)

Und lange Stücke gibt es hier zu hören:
https://open.spotify.com/playlist/6jNYZ ... g3QHH3b3u5

In dieser Playlist ist das Problem zuletzt häufiger aufgetreten.

Gruß,
Alexander

macfly1988
Beiträge: 12
Registriert: 11. April 2019 18:51
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox Server läuft auf: Windows 10 Rechner

Re: Spotty Wiedergabe bricht bei langen Stücken ab und springt zum nächsten Titel

Beitrag von macfly1988 » 16. September 2019 16:13

Leider kein Erfolg...

Das Tschaikowsky-Klavierkonzert ging noch durch, aber bei der Rhapsody in Blue ist er wieder zwei Minuten vor Schluss zum nächsten Track gesprungen...

macfly1988
Beiträge: 12
Registriert: 11. April 2019 18:51
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox Server läuft auf: Windows 10 Rechner

Re: Spotty Wiedergabe bricht bei langen Stücken ab und springt zum nächsten Titel

Beitrag von macfly1988 » 16. September 2019 17:53

Jetzt gibt’s allerdings seit dem Update auf 7.9.2 ein weiteres Problem:
Auf einmal werden alle Playlist-Einträge mit Sonderzeichen nicht mehr eingelesen. Vorher war das kein Problem.

Was kann man da machen?

Danke und Gruß,
Alexander

karlek
Moderator
Beiträge: 1522
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: Spotty Wiedergabe bricht bei langen Stücken ab und springt zum nächsten Titel

Beitrag von karlek » 17. September 2019 07:13

Ich teste diese Playlist immer mal wieder — bisher kein vorzeitiger Sprung.

España lief auch, aber das war über Connect. Wie es aussieht, wenn ich die Playlist über Spotty starte, muss ich noch testen.

Spotty ist bei Dir aktuell?

macfly1988
Beiträge: 12
Registriert: 11. April 2019 18:51
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox Server läuft auf: Windows 10 Rechner

Re: Spotty Wiedergabe bricht bei langen Stücken ab und springt zum nächsten Titel

Beitrag von macfly1988 » 17. September 2019 14:59

Spotty 2.8.4

karlek
Moderator
Beiträge: 1522
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: Spotty Wiedergabe bricht bei langen Stücken ab und springt zum nächsten Titel

Beitrag von karlek » 19. September 2019 21:42

Also mein Test mit Deiner Playlist gestaltet sich herausfordernd: es ist echt hart bei so einem 20min-Teil auf das Ende achtzugeben, insbesondere da mir die Muße fehlt, die Musik so lange zu genießen. Aber bisher kann ich nur sagen: keine Probleme bemerkt.

Und zu den Sonderzeichen bräuchte ich auch noch Beispiele.
Und die Ausgabe des Logitech Media Servers im Webinterface des LMS unter Einstellungen->Informationen zeigt vielleicht, welcher Zeichensatz bei Dir eingestellt ist.

Aber im Grunde meine ich, bei mir funktioniert alles soweit.