LMS - Tidal

mothoople
Beiträge: 3
Registriert: 1. April 2016 13:31

LMS - Tidal

Beitrag von mothoople » 11. Mai 2018 13:14

Hallo,

Tidal lief auf Version 7.7.2 (auf einem Qnap NAS) problemlos.
Nach dem Update auf 7.9.1 macht der Stream erhebliche Probleme:
- Beim Abspielen eines Albums wird direkt der 2. Titel angewählt. Abgespielt wird nichts, es wird gepuffert ohne Ende.
- Auch bei der Auswahl weiterer Alben wird zwar der 1. Titel ausgewählt jedoch abgespielt wird immer noch nichts, wieder puffern.
- Erst ab dem vierten, fünften Album läuft es reibungslos.

Genau das selbe habe ich beim Zugriff auf den LMS auf meinem PC (Version 7.9.1)

Nachdem ich wieder zurück auf 7.7.2 bin, streamt Tidal reibungslos.

Gerne würde ich die 7.9 nutzen.

Vielen Dank für evtl. Hilfe!

karlek
Moderator
Beiträge: 1477
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: LMS - Tidal

Beitrag von karlek » 18. Mai 2018 23:21

Ich habe kein Tidal (mehr) und kann somit nicht mit Informationen aus erster Hand dienen, aber Deine Probleme sind im slimdevices-Forum nicht bekannt, falls ich beim Querlesen nichts überlesen habe.

Du könntest mal auf die 7.9.1 Release-Version updaten, falls noch nicht geschehen, oder gleich zu der neuen Nightly-Reihe 7.9.2 greifen. Eventuell hilft das schon, wobei das ein Schuss ins Blaue wäre.

Du kannst auch mal das Server.log durchschauen. Eventuell müsstest Du im Webinterface auf der Einstellungsseite unter Erweitert-Protokolle das Logging für Tidal auf Debug stellen. Vielleicht findet man dort Hinweise.

mothoople
Beiträge: 3
Registriert: 1. April 2016 13:31

Re: LMS - Tidal

Beitrag von mothoople » 19. Mai 2018 15:32

Vielen Dank für die Hinweise,
das Problem tritt sowohl bei 7.9.1 als auch bei 7.9.2 auf.

Ich vermute, dass Flac Dateien erwartet werden, die ich aber nicht aboniert habe.
Zumindest interpretiere ich so die Zeilen der Log- Datei:
[18-05-19 14:40:38.3221] Slim::Plugin::WiMP::ProtocolHandler::_gotTrackError (235) Error during getTrackInfo: Requested quality is not allowed in user's subscription
[18-05-19 14:40:38.3263] Slim::Plugin::WiMP::ProtocolHandler::_getTrack (179) Getting next track playback info from SN for wimp://74018336.flac
[18-05-19 14:40:39.1880] Slim::Plugin::WiMP::ProtocolHandler::new (57) Remote streaming TIDAL track: http://ab-pr-ak.audio.tidal.com/de8e404 ... 004_18.mp3?

Kann es sein, dass für 7.7 und 7.9 unterschiedliche Plugins angeboten werden?
Das Plugin in 7.7.2 trägt einfach die Bezeichnung "Tidal",
das Plugin in 7.9.2 dagegen "Tidal - High Fidelity Music Streaming".

Vielen Dank für die Hilfe

karlek
Moderator
Beiträge: 1477
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: LMS - Tidal

Beitrag von karlek » 19. Mai 2018 21:48

Also, ich habe mal Tidal installiert, und gesehen, dass man unter der Anwendung "TIDAL" die Möglichkeit hat, die "Stream-Qualität" einzustellen. Da gibt es bei mir "FLAC oder MP3" und "MP3".

Hast Du es schon mit der letzten Auswahl getestet?

Bei mir kommt diese Meldung übrigens auch, wenn ich eine MP3 abspielen lassen will. Aber mein Abo ist ja auch schon lange ausgelaufen.

mothoople
Beiträge: 3
Registriert: 1. April 2016 13:31

Re: LMS - Tidal

Beitrag von mothoople » 20. Mai 2018 09:39

Hallo karlek, vielen Dank das war es wohl.

Unter Tidal muss wohl die Stream Qualität "FLAC oder MP3" und "MP3" auf MP3 gesetzt werden. Dies obwohl dort vermerkt ist "FLAC steht nur zur Verfügung, wenn Sie über TIDAL HiFi verfügen. Andernfalls wird automatisch MP3 verwendet."

Was soll's, so läuft Tidal jetzt auch unter LMS 7.9.2 einwandfrei!

karlek
Moderator
Beiträge: 1477
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: LMS - Tidal

Beitrag von karlek » 20. Mai 2018 10:19

mothoople hat geschrieben:Hallo karlek, vielen Dank das war es wohl.

Unter Tidal muss wohl die Stream Qualität "FLAC oder MP3" und "MP3" auf MP3 gesetzt werden. Dies obwohl dort vermerkt ist "FLAC steht nur zur Verfügung, wenn Sie über TIDAL HiFi verfügen. Andernfalls wird automatisch MP3 verwendet."

Was soll's, so läuft Tidal jetzt auch unter LMS 7.9.2 einwandfrei!
Ja, das hätte ich jetzt auch so wie Du verstanden.
Vermutlich wählt er aber dann, wenn vorhanden, den FLAC-Stream und der ist Dir verboten.

Raspy
Beiträge: 6
Registriert: 12. April 2018 12:19
SqueezeBox Server läuft auf: Raspberry 3: Picoreplayer

Re: LMS - Tidal

Beitrag von Raspy » 2. Juni 2019 16:48

Hallo zusammen,
eigentlich läuft Tidal mit ICkstream perfekt.
Doch leider habe ich mit dem aktivierten ickstream-Plugin kein Zugriff mehr auf meinen LogitechMedia-Server.

Könnt ihr das bei euch auch bestätigen? Gibt es schon Lösungansätze?
Vielen Dank und viele Grüße
Jonas

karlek
Moderator
Beiträge: 1477
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: LMS - Tidal

Beitrag von karlek » 2. Juni 2019 16:52

Ickstream hat vor ein paar Tagen seinen Dienst eingestellt. Wenn es daran liegt, müsstest Du das Plugin wohl von Hand löschen.

Edit: Auf meinem Rasperry Pi mit Debian Jessie liegen die Plugins unter

Code: Alles auswählen

/var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins
Edit 2: Link ins SlimDevices-Forum eingefügt.

Raspy
Beiträge: 6
Registriert: 12. April 2018 12:19
SqueezeBox Server läuft auf: Raspberry 3: Picoreplayer

Re: LMS - Tidal

Beitrag von Raspy » 2. Juni 2019 21:12

@karlek, vielen Dank für die schnelle Hilfe.

karlek
Moderator
Beiträge: 1477
Registriert: 2. November 2011 12:35
SqueezeBox: Touch
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Classic
SqueezeBox: Transporter
SqueezeBox Server läuft auf: Raspberry Pi 3 (Jessie) mit LMS 7.9
(O2 Joggler mit LMS 7.9)
(QNAP-212 (Turbo) mit LMS 7.9)

Re: LMS - Tidal

Beitrag von karlek » 2. Juni 2019 22:46

Gerne. Hat es denn zum Erfolg geführt? Es war letzten Endes nur eine Idee. :)