Massive WLAN-Probleme

Benutzeravatar
Boogie2005
Beiträge: 71
Registriert: 17. Juli 2020 13:07
SqueezeBox: Radio
SqueezeBox Server läuft auf: Raspberry 4 mit piCorePlayer und LMS 8

Re: Massive WLAN-Probleme

Beitrag von Boogie2005 »

@MarkusLehmann habe nun seit dem Update der Fritte 7590 auf 7.57 auch diese Problem. Habe deinen Tipp nun mal eingebaut, Zeile 29 # auskommentiert. Ich hoffe, es wird helfen! Danke dafür!
Benutzeravatar
LudgerH
Beiträge: 3
Registriert: 26. September 2023 12:44
SqueezeBox: Classic
SqueezeBox Server läuft auf: Debian Linux
Wohnort: Aachen / Kalymnos

Re: Massive WLAN-Probleme

Beitrag von LudgerH »

...bei mir ist es eine Fritzbox, die nach dem letzten Firmware-Update sehr ähnliche Probleme verursacht. Eine gute Konfigurations-Lösung habe ich trotz extensiver Googelei nicht gefunden. Jetzt versuche ich es mit einem Hardware Implantat. Details hier:
viewtopic.php?t=4144
Benutzeravatar
Boogie2005
Beiträge: 71
Registriert: 17. Juli 2020 13:07
SqueezeBox: Radio
SqueezeBox Server läuft auf: Raspberry 4 mit piCorePlayer und LMS 8

Re: Massive WLAN-Probleme

Beitrag von Boogie2005 »

Boogie2005 hat geschrieben: 21. September 2023 09:13 @MarkusLehmann habe nun seit dem Update der Fritte 7590 auf 7.57 auch diese Problem. Habe deinen Tipp nun mal eingebaut, Zeile 29 # auskommentiert. Ich hoffe, es wird helfen! Danke dafür!
Ich zitiere mich mal: Es läuft noch immer ohne Probleme, keine Unterbrechungen mehr.
desperado591
Beiträge: 9
Registriert: 28. Oktober 2023 15:32
SqueezeBox: Radio
SqueezeBox Server läuft auf: gar nicht mehr :(

Re: Massive WLAN-Probleme

Beitrag von desperado591 »

Ich bin per Google Suche auf diesen Thread gestoßen, nachdem vor einigen Tagen eine neue FritzBox bei mir Einzug gehalten hat und ich seitdem jeden Morgen keine W-Lan Verbindung mehr habe zu meinem Squeezebox Radio.

Nun wollte ich das mit dem Auskommentieren in der Datei WLAN einmal ausprobieren und habe mir dabei selbst einen Bock geschossen :shock:
Kurz abgelenkt gewesen, vergessen die Datei vorher auf meinen Rechner zu sichern und schwups ist die Datei WLAN nun bei mir leer :oops:

Ich habe schon versucht auf der Squeezebox die Software (Firmware?) erneut zu installieren, aber leider bleibt die WLAN Datei weiterhin leer.

Könnte mir vielleicht jemand den Text aus seiner Datei hier einstellen, damit ich mir den wieder in meine Box reinkopieren kann?

Vielen lieben Dank im Voraus für jegliche Hilfe!
Benutzeravatar
MarkusLehmann
Beiträge: 12
Registriert: 3. November 2012 21:46
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Boom
SqueezeBox Server läuft auf: Windows 11
Wohnort: Wolfach

Re: Massive WLAN-Probleme

Beitrag von MarkusLehmann »

#!/bin/sh

case "$1" in
start)
/usr/bin/logger -s "wlan: starting"

# Load wlan drivers
export WORKAREA=/lib/atheros
export EEPROM=${WORKAREA}/calData_ar6102_15dBm.bin

# Set MAC address to the same as Ethernet
macaddr=`/sbin/ifconfig eth0 | sed -ne 's/.*\(..:..:..:..:..:..\).*/\1/p'`
if [ "x${macaddr}" != "x" ]
then
echo "Setting eth1 macaddr: ${macaddr}"
SETMAC="--setmac $macaddr"
fi

/lib/atheros/loadAR6000l.sh $SETMAC
if [ $? -ne 0 ]; then
/usr/bin/logger -s "wlan: failed"
exit -1
fi

/lib/atheros/wmiconfig -eth1 --filter=all

# Temporary possible work-a-round to fix wireless connectivity issues
# Disable power save mode
#/lib/atheros/wmiconfig -eth1 --power maxperf

# todo region codes?

# Start wpa_supplicant
/usr/bin/logger "Starting wpa_supplicant"
/usr/sbin/wpa_supplicant -B -Dwext -ieth1 -c/etc/wpa_supplicant.conf
/usr/sbin/wpa_cli -B -a/etc/network/wpa_action
/usr/bin/logger "Started wpa_supplicant"

/usr/bin/logger -s "wlan started"
;;

stop)
/usr/bin/logger -s "wlan: stopping"

# Stop wpa supplicant
killall wpa_cli
killall wpa_supplicant

# todo Make sure udhcpc is killed
if [ -r /var/run/udhcpc.eth1.pid ]
then
PID=`cat /var/run/udhcpc.eth1.pid`
kill -TERM $PID

# Wait until udhcpc is dead
kill -0 $PID >/dev/null 2>&1
while [ $? == 0 ]; do
sleep 1
kill -0 $PID >/dev/null 2>&1
done
fi

# remove wlan driver
/lib/atheros/loadAR6000l.sh unloadall

/usr/bin/logger -s "wlan stopped"
;;

*)
echo "Usage: $0 {start|stop}"
exit 1
esac

exit 0
desperado591
Beiträge: 9
Registriert: 28. Oktober 2023 15:32
SqueezeBox: Radio
SqueezeBox Server läuft auf: gar nicht mehr :(

Re: Massive WLAN-Probleme

Beitrag von desperado591 »

Super, vielen lieben Dank! :D

Ich sehe das richtig, daß in dieser Version die Zeile 29 noch nicht auskommentiert ist, ja?
Benutzeravatar
MarkusLehmann
Beiträge: 12
Registriert: 3. November 2012 21:46
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Radio
SqueezeBox: Boom
SqueezeBox: Boom
SqueezeBox Server läuft auf: Windows 11
Wohnort: Wolfach

Re: Massive WLAN-Probleme

Beitrag von MarkusLehmann »

Doch, ist auskommentiert, das Rautezeichen # steht am Anfang
desperado591
Beiträge: 9
Registriert: 28. Oktober 2023 15:32
SqueezeBox: Radio
SqueezeBox Server läuft auf: gar nicht mehr :(

Re: Massive WLAN-Probleme

Beitrag von desperado591 »

Ups, bin in der Zeile verrutscht - war wohl gestern Abend schon zu spät für mich ;)

Also vielen lieben Dank nochmal für die Hilfe!

Übrigens: Der Tipp mit dem Austausch der alarm.mp3 hat super funktioniert und ich wurde heute nicht von einem nervigen Jingle geweckt, sondern von meinem Lieblingskünstler :lol:
Jetzt muss ich nur noch meine wlan Datei wieder richten und dann schauen wir mal, ob das auch funktioniert.
desperado591
Beiträge: 9
Registriert: 28. Oktober 2023 15:32
SqueezeBox: Radio
SqueezeBox Server läuft auf: gar nicht mehr :(

Re: Massive WLAN-Probleme

Beitrag von desperado591 »

So, noch ein kurzes Feedback, denn davon lebt ja ein Forum:

Seit der (mittlerweile erfolgreichen) Auskommentierung funktioniert mein Wecker wieder wie er soll und verbindet sich morgens brav mit dem Internet per W-LAN.

Vielen Dank erneut für Eure Hilfe!
ElGuapo
Beiträge: 1
Registriert: 11. November 2023 11:37

Re: Massive WLAN-Probleme

Beitrag von ElGuapo »

Moin,

Ich habe ebefalls noch vier SB Radios rumstehen und bin nach wie vor sehr zufriden damit. Dass die Hardware nach über 10 Jahren wohl nicht mehr sauber mit modernen WLAN-APs klarkommt ist zwar schwierig zu verstehen, aber wohl Tatsache.

Anyways, ich habe (wie viele hier) die letzten Jahre immer wieder mal mit Problemen zu kämpfen, habe dann jeweils alle einschlägigen Boards abgegrast und ziemlich viele Tipps angewendet - manchmal mit, manchmal ohne Erfolg. Nun, vor einem Jahr hatte ich die Nase endgültig voll und eine radikale Lösung - die aber wirklich Bestens funktioniert - gewählt.

Ich investierte $60 für vier dieser Teile hier beim freundlichen Chinesen ums Eck sowie weitere $4 für vier Weichen der DC-Steckverbinder. Die Geräte haben Masse von 45x45x15 mm, lassen sich über die Steckerweichen vom SB Netzteil mitversorgen und sind durchaus diskret hinter dem Radio versteckt.

Seither ist Ruhe. Die SBs sind per Ethernet angebunden und tun anstandslos ihren Dienst. Ich kann den Ansatz echt empfehlen.